Author Topic: Forum sometimes loads very slow  (Read 40 times)

0 Members and 1 Guest are viewing this topic.

Offline barbeque

  • Silly Filly
  • Posts: 19
  • h
    • View Profile
Forum sometimes loads very slow
« on: January 28, 2019, 10:07:51 am »
This isn't anything related to the game or the MLK songs, but the forum.

Sometimes, it takes very long to load. This is especially bad the first time I open it.

The problem is this URL that gets called:
https://www.mylittlekaraoke.com/forum/index.php?scheduled=mailq;ts=1548667093

Especially the first time, it takes over 40 seconds to respond, and during that the tab icon remains spinning etc. In the response headers is also something that says it "expires: Mon, 26 Jul 1997 05:00:00 GMT" which is not useful at all.
It (eventually) returns a 1x1 gif.

Googling around suggests it's some kind of thing that makes sure the emails get sent, but I'm not sure why it takes over 40 seconds. Not sure if it's easy to fix or can be fixed at all (don't bother looking into this more than a few minutes) but if it's something easy like the mail queue being full of failed email to dead email addresses, just clear it and edit those accounts to never get an email or something.
i am best barbeque. put your hamburgers on me.

Online Renard

  • Administrator
  • Silly Filly
  • Posts: 1 630
  • aka "MairusuPawa"
    • View Profile
Re: Forum sometimes loads very slow
« Reply #1 on: January 28, 2019, 09:01:01 pm »
That mail queue theory might just be true. I checked, and it may be possible that one of our members has been infected by a spambot, which in turned tried to use the forum's notifications feature to spam all other members. Thanks to security measure it failed at doing this, but tentatively filled up the email queue in the meantime.

For some reason I've never noticed the slowdowns. I've pruned all email-related growing logs and unsent emails anyway, because it was mostly full of junk. I've also disabled email notifications for the time being. Do tell me if things are better now ;)

Offline barbeque

  • Silly Filly
  • Posts: 19
  • h
    • View Profile
Re: Forum sometimes loads very slow
« Reply #2 on: February 16, 2019, 05:51:11 pm »
Sorry for the really late reply (because... I didn't get an email notification of it, lol), but yes, these past few weeks I haven't experienced the issue.
i am best barbeque. put your hamburgers on me.