Author Topic: [SOLVED] Microphone not registering (voicemeeter + voicemod setup on Windows 10)  (Read 423 times)

0 Members and 1 Guest are viewing this topic.

Offline GliconCraft

  • Silly Filly
  • Posts: 2
  • Meep!
    • View Profile
Hello! The last time I used MLK, I never used voicemeeter or voicemod, but recently I've acquired both, and my main audio management is handled through voicemeeter (potato edition specifically), and my main microphone output is handled by voicemod.

A few things to note, the game itself is actually accessing my microphone, I know this because when I go into the Record options page, and my "Soundcard" option is set to "Microphone (Voicemod Virtual Audio Device (WDM))", upon creating vocal sounds you can see the Channel 1 and Channel 2 preview bars display the feedback of me speaking into the mic. Additionally, when Microphone Playback is enabled in the Sounds page, I can hear myself talking while on the Record settings page.

Now, the issue happens when I try to play through a song, when I start a song, the visual feedback wave thing doesn't respond at all, it stays a flat line. Additionally, if Microphone Playback is enabled, it doesn't play any sound. So, the game can access my mic when I'm on the settings page, but when I back out of or confirm those settings, it does not register when a song is playing.

Thank you for taking the time to read through my issue, hope you can help! ;D
« Last Edit: April 02, 2020, 02:48:10 pm by GliconCraft »

Online barbeque

  • Crystal Pony
  • Silly Filly
  • Posts: 71
  • h
    • View Profile
Does it have an "Assigned Player" (or whatever it's called, it's the one below the "Channel" I think)? Because it sounds like it should work at this point, or at least it shouldn't be a flat line in-game.

Also check all the other sound cards/channels to see if something is still mapped to a player that shouldn't be.

(disclaimer: I don't run this on Windows, nor do I have these extra applications. But it shouldn't really matter)
i am best barbeque. put your hamburgers on me.

Offline GliconCraft

  • Silly Filly
  • Posts: 2
  • Meep!
    • View Profile
You saved me! Thanks ;D

I guess as it turns out I wasn't assigned to the correct microphone - Voicemod (Virtual Audio Device WDM) is what my audio goes through, and both channels were set to Off. I became confused because when I tried setting the first channel to 1, it would tell me that Player 1 was assigned to multiple microphones, so I just set it back to off and figured that wasn't the right thing to be looking into.

After you mentioned your suggestions, I went back in and the same thing happened, and then I thought about it, it's saying I'm assigned to multiple microphones, so I scrolled through the settings, and it turned out I was still set to "1" on my previous microphone "soundcard" option, which doesn't have a mic output anymore because that mic feeds exclusively into Voicemod. So, I set that mic's Channel 1 to off, set Voicemod to 1, and now it works!

Thank you very much! I'm not sure if I can rename the post to have [SOLVED] in it, but if anyone has that sort of power then feel free to! I'll look after I've posted this.

I've written important lines in bold for future reference, if anyone else comes here with a similar issue.
« Last Edit: April 02, 2020, 02:49:49 pm by GliconCraft »